Access, MXL (Blade)

Force10 MXL configuration – Data fabric for M1000e blade chassis

.

If you see an issue where the MXL switch refuses to boot when placed in the M1000e chassis, be mindful that this may not be a hardware issue. the previous MXL firmware version, specifically version 8.3.16.1, does not support M1000e midplane version 1.0. This however, is resolved in the new revision 8.3.16.2. this is only relevant where you have midplane version 1.0 (check in CMC console via $getsysinfo)

.

This is the Second of three posts on MXL blade switches. The first gave an overview of the switch, while the third gives configuration details for setting these up as iSCSI fabrics, within M1000e Blade Chassis. The posts can be accessed here:

.

For this setup, please be advised that the switches are being used in slots A1 and A2 of the M1000e chassis. The data fabric is not stacked, thus both the switches A1 and A2 are standalone. both have individual uplinks to the upstream LAN switch stack (Cisco).

.

Stanzas Mode/Prompt Commands Parameters Comments
  You can copy and paste columns C & D into the CLI. Make sure to edit the values in column D.
Global
FTOS# conf If uplinking to Cisco, use PVST to ensure compatibility. If uplinking to Powerconnect, or any other brand that does not support PVST, use RSTP.
FTOS(conf)# protocol spanning-tree pvst
FTOS(conf-rstp)# no disable
FTOS(conf-rstp)# edge-port bpdufilter default
FTOS(conf-rstp)# exi
Ports
FTOS(conf)# int range tengigabitethernet 0/1 – 32
FTOS(conf-if-range-te-0/1-32,te-1/1-32)# switchport Define internal ports as Layer 2, portfast enabled.
FTOS(conf-if-range-te-0/1-32,te-1/1-32)# spanning-tree pvst edge-port
FTOS(conf-if-range-te-0/1-32,te-1/1-32)# no shut
FTOS(conf-if-range-te-0/1-32,te-1/1-32)# exi
FTOS(conf)# int tengigabitethernet 0/52 Define an individual uplink as layer 2. if multiple ports are to be configured, use the range command as shown in the syntax above.
FTOS(conf-if-te-0/53)# switchport
FTOS(conf-if-te-0/53)# no shut
FTOS(conf-if-te-0/53)# exi
VLAN
FTOS(conf)# interface vlan 10 Create any production/Data VLAN needed. Do not use VLAN 1.
FTOS(conf-if-vl-10)# name Production
FTOS(conf-if-vl-10)# no shutdown
Next, assign the port memberships under the VLAN.
FTOS(conf-if-vl-10)# untagged tengigabitethernet 0/1-32 passing a native (untagged) VLAN to internal blades
FTOS(conf-if-vl-10)# tagged tengigabitethernet 49 passing the same VLAN as tagged on the uplink to LAN/Core Switches.
FTOS(conf-if-vl-10)# exi
FTOS(conf)# interface vlan 20 Create any other Data VLANs needed.
FTOS(conf-if-vl-20)# name Prod_2
FTOS(conf-if-vl-20)# no shutdown
Next, assign the port memberships under the VLAN.
FTOS(conf-if-vl-20)# tagged tengigabitethernet 0/1-32 This time, we pass this second VLAN as tagged to blades.
FTOS(conf-if-vl-20)# tagged tengigabitethernet 49 Passing the  VLAN as tagged on the uplink to LAN/Core Switches.
FTOS(conf-if-vl-20)# exi
Define as many VLAN/port memberships as needed, with the template above.
OOB
FTOS(conf)# interface ManagementEthernet 0/0 Define the OOB Management address. OOB connectivity is provided via the CMC, there is no dedicated port on the external plane.
FTOS(conf-if-ME-0/0)# ip address 192.168.0.10/24
FTOS(conf-if-ME-0/0)# no shutdown
FTOS(conf-if-ME-0/0)# exi
FTOS(conf)# management route 0.0.0.0/0 192.168.0.1 Using 192.168.0.10 and next hop 192.168.0.1 as example.
VTY
FTOS(conf)# line vty 0 Allow telnet connections to the switch with the deault authentication list
FTOS(config-line-vty)# login authentication default
FTOS(config-line-vty)# exi
FTOS(conf)# username sample password sample priv 15
Advertisements

About Hasan Mansur

Hasan Mansur --------------------- bis vincit qui se vincit in victoria.

Discussion

One thought on “Force10 MXL configuration – Data fabric for M1000e blade chassis

  1. That’s an apt asnwer to an interesting question

    Posted by Nathaly | March 20, 2013, 12:20 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: