Campus, Configuration, Data Center, Dell EMC Networking, Storage Networking

PowerConnect 8024 – Sample iSCSI Configuration – LAGged (Non-Stacked)

.

First, I would highly recommend you have a view of my earlier post that summarizes the various (platform independent) optimizations you can implement on an iSCSI fabric. These could be configured upfront, or tried  re-actively in case you have any performance or packet loss issues. the post can be found here https://hasanmansur.com/2012/10/14/switch-fabric-setup-for-equalogic-iscsi-powerconnect-switches/

This is the second of the two installments on configuring Powerconnect 8024 as iSCSI switches. The first one covered stacked configuration of these switches, and can be found here http://wp.me/s2OfK0-357. In this post, i intend to provide the details on configuring the 8024 switches in a LAGged, Non-stacked configuration. Topology-wise, most of the details are inherited from the first post for stacked config, except for the following differences:

  • Stacking inter-connects have been replaced with LAGs between the two switches.
  • The fabric is isolated, i.e. it does not have uplinks to any Core/Edge Switches. If such uplinks are needed, one has to be mindful of the fact that unlike the stacked config, where you could have a LAG/Port channel split across both switches, going to an upstream single logical switch/chassis, the same cannot be done here. As the switches are LAGged, they are two distinct chassis. Thus, you cannot “Split” channels or LAGs across both switches. such capability can be provisioned through Force10 VLT, Cisco vPC, or other MLAG implementations, but only for the downstream switches. there is no equivalent option available on Powerconnect 8024. Thus, you can have a link each from both switches, going to an upstream switch, multiple links from each 8024 going to an upstream switch, or single/multiple links going to multiple upstream switches. All the topologies are possible, but you have to plan out the STP priorities beforehand to make the forwarding topology of your network, deterministic. STP would likely block one of the alternate paths, and retain it as a backup.

 

Here goes:

.

PowerConnect 8024 – iSCSI Fabric – Non-Stacked, LAGged Configuration. Single iSCSI VLAN. No Core uplinks.
Column C can be pasted into the Switch Console CLI. Make sure to update any values that need revision, or remove any sections not needed. All sections may not be required.
All these commands will have to be carried out on both switches individually.
console> en
console# config
console(config)# username root password xxxxx privilege 15
Telnet
console(config)# line telnet To prompt for user/pass,  no prompt for entering enable mode.
console(config-telnet)# enable authentication default
console(config-telnet)# exi
SSH show crypto key mypubkey
console(config)# crypto key generate dsa if SSH needs to be enabled.
console(config)# crypto key generate rsa
console(config)# ip ssh server
console(config)# line ssh
console(config-ssh)# enable authentication default To prompt for user/pass,  no prompt for entering enable mode.
console(config-ssh)# exi
console(config)# ip telnet server disable if you want to only keep ssh access, and disable telnet
HTTPS
console(config)# crypto certificate 1 generate if HTTPS needs to be enabled.
console(config-crypto-cert)# key-generate
console(config-crypto-cert)# exi
console(config)# ip http secure-certificate 1
console(config)# ip http secure-server
console(config)# no ip http server if you want to disable http access
OOB
console(config)# interface out-of-band show ip int out-of-band
console(config)# ip address x.x.x.x 255.255.255.0  y.y.y.y where y is the next hop gateway for OOB Management
VLAN
console(config)# vlan database Only a single VLAN being created here, making this a dedicated fabric for iSCSI
console(config-vlan)# vlan 30
console(config-vlan)# exit
console(config)# vlan 30
console(config-vlan60) name “iSCSI VLAN”
console(config-vlan60) exi
console(config)# interface vlan 30 A Layer 3 VLAN interface is not needed on isolated fabrics. If one is needed, this section can  be used.
console(config-if-vlan30)# ip address x.x.x.x 255.255.255.0
console(config-if-vlan30)# exit
console(config)# ip default-gateway y.y.y.y if in-band management access to this interface is needed from outside the subnet.
Server Ports console(config)# interface range tengigabitethernet 1/0/x-xx,te2/0/x-xx
console(config-if)# description “Server Ports – Not Teamed”
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 30
console(config-if)# spanning-tree portfast
console(config-if)# spanning-tree tcnguard
console(config-if)# mtu 9216
console(config-if)# exi
console(config)# interface range tengigabitethernet 1/0/x-xx,te2/0/x-xx
EQL – Storage Ports console(config-if)# description “EQL ports – STP disabled”
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 30
console(config-if)# spanning-tree disable
console(config-if)# mtu 9216
console(config-if)# no storm-control unicast (disabled by default already)
console(config-if)# exi
ISL – LAG to InterConnect the 2 PC switches console(config)# interface range tengigabitethernet 1/0/x-xx This is the LAG/Port Channel between the two iSCSI PC switches.
console(config-if)# channel-group 1 mode active LACP is being used (mode Active)
console(config-if)# description “Member PoCH 1 – LAG to Partner iSCSI switch”
console(config-if)# exi
console(config)# interface port-channel 1
console(config-if)# switchport mode access
console(config-if)# switchport access vlan 30
console(config-if)# mtu 9216
console(config-if)# description “PC iSCSI LAG – mode LACP”
console(config-if)# exi
console# copy run start

About Hasan Mansur

Hasan Mansur --------------------- bis vincit qui se vincit in victoria.

Discussion

One thought on “PowerConnect 8024 – Sample iSCSI Configuration – LAGged (Non-Stacked)

  1. Great thing. Ty a lot

    Posted by Anonymous | February 14, 2013, 2:33 pm

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: