Simple CoS DSCP VOIP config | N-Series, Dell EMC Networking

A sample config for N-Series VOIP Config, via DSCP/CoS assignment.

————–

configure

vlan 10,11,12

exit

vlan 10

name “Management”

exit

vlan 11

name “Data”

exit

vlan 12

name “Voice”

exit

!

ip routing

interface vlan 1

no ip address

exit

interface vlan 10

ip address 10.0.10.1 255.255.255.0

exit

interface vlan 12

ip address 10.0.12.1 255.255.255.0

exit

ip default-gateway 10.0.10.254

!

spanning-tree mode pvst

spanning-tree loopguard default

spanning-tree portfast default

!

 

 

 

classofservice ip-dscp-mapping 0 0

classofservice ip-dscp-mapping 8 1

classofservice ip-dscp-mapping 16 2

classofservice ip-dscp-mapping 26 3

classofservice ip-dscp-mapping 32 4

classofservice ip-dscp-mapping 46 5

classofservice ip-dscp-mapping 48 6

classofservice ip-dscp-mapping 56 6

!

cos-queue min-bandwidth 70 2 2 2 2 10 2

!

voice vlan

cos-queue strict 5

diffserv

!

class-map match-all class_Traffic_VOIP

match protocol udp

match ip dscp ef

exit

class-map match-all class_VLAN_VOIP

match vlan 12

exit

policy-map pol_voip in

class  class_Traffic_VOIP

assign-queue 5

exit

class class_VLAN_VOIP

mark ip-dscp ef

assign-queue 5

exit

exit

!

interface range gi 1/0/1-23

switchport mode general

switchport general allowed vlan add 11

switchport general allowed vlan add 12 tagged

switchport general pvid 12

voice vlan 12

voice vlan dot1p 5

classofservice trust dot1p

spanning-tree portfast

service-policy in pol_voip

exit

!

interface Gi 1/0/24

switchport mode general

switchport general allowed vlan remove 1-4093

switchport general allowed vlan add 10,11,12 tagged

switchport general allowed vlan add 10

switchport general pvid 10

service-policy in pol_voip

exit

!

exit

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s